Anyone for got v0.4.5 Working on ESXi 5.0?

Support section for FREESCO v0.4.x

Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Sun May 11, 2014 4:25 pm

anyone got v0.4.5 working on ESXi 5.0.

I've got v0.3.3 working on ESXi 5.0 and VMware Workstation 6.5, but v0.4.5 just panics and crashes at mounting on both ESXi 5.0 and VMware Workstation 6.5.

I've also download the OVA from Ntpro.nl and the same happenes, it crashes.

Tried different storage controllers, memory, Linux version, v0.4.5 just does not seem happpy.

Any ideas ?
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby Lightning » Sun May 11, 2014 6:46 pm

I have had v0.4.5 running on VMworkstation 6.0 without any issues, however from memory there needs to be some special stuf done with the processor in newer version to get FREESCO to run. The primary issue with the newest version is that the ramdisk is quite a bit bigger than older versions of FREESCO. Which could be the issue with ESXi, but I really am not sure. I have in the past created ESXi compatible versions on my VMworkstation. But under normal circumstances just adding the floppy image should work fine by adding a .img or .bif extension to it. Also just using a DOS hard drive type is usually the best for FREESCO.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12079
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Mon May 12, 2014 11:20 am

if I attach the freesco.045 floppy image to a VMware Workstation 6.5 VM, using FreeBSD or Linux template, and just let it BOOT....after Mounting it crashes....and I don't understand why, in both Hypervisors. (it does not do it in 0.3.3)

here's a you tube video, I quickly did....

http://youtu.be/O2rtB3HidKc
could you share your VM template?

e.g. settings etc ?
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby Lightning » Mon May 12, 2014 8:40 pm

I could make a template that is ESX 3.x compatible, but that is a limit with VMWorkstaion 6.0 that I am using.

However looking at the video I see that everything is fine right up to the point that it tries to mount the floppy and then the first image is "Protected Mode" before all of the core dumps. So make certain that you add and extension of ".img" to the freesco.045 disk image and also look through the options for the floppy controller and make certain there is no protected mode in the configuration along with making sure the file permissions on that file are set to read and write.
As a secondary option it might be possible to use the .iso CD version of FREESCO on ESX, but I am not sure on that as it would need an IDE controller and at least on ESX 3.x there is no IDE support and changing the kernel to support SCSI is not really simple on a CD.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12079
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Tue May 13, 2014 2:42 am

Thanks for your post.

I'd already tried renaming to *.flp and *.img, and it makes no difference on VMware Workstation 6.5, I'm going to try those extensions on ESXi, which is where I'd rather like the VM. I'll aloso try on VMware Workstation 8.0 and 9.0/10.0, and also checked the image can be read and written, and there is no read protection on the disk.
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Tue May 13, 2014 5:51 am

Okay, some more confusion, I've tried the floppy (rename as *.flp) on ESXi 5.5, and it boots fine, and I get the little tune, and menu to proceed. This was tested on Intel Hosts, the other tests were on ESXi 5.0 and AMD hosts.

I've also tested on VMware Workstation 8.0.4 and working fine, so I'm going to congfigure and then export, and import into ESXi 5.0!
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Tue May 13, 2014 4:28 pm

still puzzled by this v0.3.3 works and boots fine on ESXi 5.0 (and I've been using v0.3.3 since ESX 2.0 with no issues) and though it time for a change!

So what's changed from v0.3.3 to v0.4.5 ?
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Tue May 13, 2014 4:39 pm

I've just tested 0.3.8 and the same issue occurs.....
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Tue May 13, 2014 4:49 pm

okay, so what ever happen after 0.3.4 works okay, but after 0.3.4 causes the protection crash, in my ESXi 5.0 (AMD) and VMware Workstation 6.5 on Intel Q6700.
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby Lightning » Tue May 13, 2014 9:45 pm

I have looked through all of the various kernel changes through all of the versions and I only see one option that changed from 0.3.4 to 0.3.5 and that is the PPtP IPSEC option was enabled. This also indicates that the kernel code was patched at that time as well to prevent the bug that plagued previous versions with that option enabled.

I do not know if you have the ability to change a kernel in a floppy image. But it can be done easily if you mount the image in a FREESCO box using this command
Code: Select all
mount ./freesco.045  /mnt/fd  -o loop

You then can copy a 034 kernel to it and "umount" the disk image and see if a 0.4.5 image will run using an older kernel.

If this is successful then you could probably continue using the older kernel without any serious side effects. There are a number of changes and enhancements to newer kernels, but nothing that is probably system critical under ESX. Although I am unsure about the network drivers if they will run with an older kernel or not.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12079
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby einsteinagogo » Wed May 14, 2014 3:31 pm

the actual reason for change, is because I wanted to use some newer addons that are for 0.4.x!

so this is really out, looks like an upgrade to ESXi 5.5, but I suspect the issue is AMD cpu related.
einsteinagogo
Newbie
 
Posts: 8
Joined: Sat May 10, 2014 4:19 pm

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby Lightning » Wed May 14, 2014 7:45 pm

Unfortunately FREESCO has always pushed the limits of the 2.0.x Linux kernel and starting in v0.3.5 was when changing the kernel source code started happening. Which prior to that the code had not changed much since the beginning of FREESCO's 03x series when I applied all of the necessary patches to the 2.0.39 Linux kernel for FREESCO. Which continued into the 04x series with the addition of the 2.0.40 kernel patch and several other custom changes.
The unfortunate side effect has been some quirky behavior in very specific hardware and Intel systems have usually not been effected as they have always been very well supported in Linux.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12079
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Anyone for got v0.4.5 Working on ESXi 5.0?

Postby AntiC » Tue May 27, 2014 4:58 am

Hi,

today I tested a freesco 0.4.5 installation on my esx 5.1 cluster (floppybased without hdd). In my first attempt I had same issue showing in your video. So I checked my other virtual freesco installations, I have some older ones with 0.3.8 and 0.4.4 for routing, dhcp and other stuff. In options they all have "cpu virtualisation" changed from "automatic" to "hardware (cpu)".

After I changed that parameter also for my 0.4.5 test server it started up and I was able to do the setup without any error.

Screenshot: http://picload.org/image/lccogli/esx5_freesco_045.jpg

regards AntiC
AntiC
Newbie
 
Posts: 9
Joined: Thu May 22, 2014 7:51 am


Return to FREESCO Support for v0.4.x

Who is online

Users browsing this forum: No registered users and 5 guests