Gigabit behaviour

Support section for FREESCO v0.4.x

Gigabit behaviour

Postby strampke » Thu May 19, 2011 2:44 pm

I changed a 100mB 3COM NIC which caused trouble for a Zyxel Gigabit card.
Freesco took the opportunity to change networks from eth1 and eth2 (swap the NICs), but that is a minor problem
One string is attached to a swith and the other to an open end with up till now no computer hanging on the other end of the line.
Look at my report.txt
----- dmesg | sed -n /eth/P -----
eth1: RealTek RTL8169 Fast Ethernet at 0xd800, IRQ=10, HWaddr=00:23:f8:5f:3a:ec
eth1: Identified chip type is 'Unknown'
eth1: Driver info tmp = '16'
eth1: Link Status = NoLink, PHY Status = 100Mbps Half-Duplex!
eth1: Auto-negotiation Enabled.
eth1: Auto-negotiation process is not completed!
eth2: RealTek RTL8169 Fast Ethernet at 0xd400, IRQ=9, HWaddr=00:23:f8:5f:3a:f3
eth2: Identified chip type is 'Unknown'
eth2: Driver info tmp = '16'
eth2: Link Status = OK, PHY Status = 1000 Full-Duplex!
eth2: Auto-negotiation Enabled.
eth2: 1000Mbps Full-duplex Link OK!

After I swapped the plugs in eth1 and eth2 my report.txt shows this:
----- dmesg | sed -n /eth/P -----
eth1: RealTek RTL8169 Fast Ethernet at 0xd800, IRQ=10, HWaddr=00:23:f8:5f:3a:ec
eth1: Identified chip type is 'Unknown'
eth1: Driver info tmp = '16'
eth1: Link Status = NoLink, PHY Status = 100Mbps Half-Duplex!
eth1: Auto-negotiation Enabled.
eth1: Auto-negotiation process is not completed!
eth2: RealTek RTL8169 Fast Ethernet at 0xd400, IRQ=9, HWaddr=00:23:f8:5f:3a:f3
eth2: Identified chip type is 'Unknown'
eth2: Driver info tmp = '16'
eth2: Link Status = OK, PHY Status = 1000 Full-Duplex!
eth2: Auto-negotiation Enabled.
eth2: 1000Mbps Full-duplex Link OK!


You might ask: "What is the problem"
Well, you may notice something about 100Mbps Half Duplex and 1000Mbps Full-duplex.
Either way:
In both situations the computers behind the switch proudly announce they have a 1.0Gbit connection.
Why o why.
Who knows knows, who doesn't doesn't.
User avatar
strampke
Junior Advanced Member
 
Posts: 151
Joined: Mon Jul 29, 2002 12:36 pm
Location: Delden, Netherlands

Re: Gigabit behaviour

Postby Lightning » Thu May 19, 2011 7:43 pm

Looking at the code of the driver it is apparent that there is a 100 millisecond delay for the auto-negotiation sequence. So I suspect because you have two cards the second card is being enabled a fraction of an instant before the first card finishes the negotiation. Which doesn't mean that it won't finish it just means that it hasn't finished yet and so the card just reports the default speed of 100Mbit half duplex instead of what it really ends up capable of doing.

Here is the same driver with a 1000 millisecond delay for the auto-negotiation to try out and see what happens

http://lewys-spot.dyndns.org/test/rtl8169.gz

As for the switch reporting it has a 1Gbit connection. That also just means the card is capable of that fast of a connection and also has very little to do with what the card is willing to put out. Because the switch speed light happens as soon as the card is plugged in and you could have the capability of forcing the driver into 10Mbit half duplex if I had left the manual speed option in the driver. Which for FREESCO I removed the command line speed options and force auto-negotiate.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Gigabit behaviour

Postby strampke » Fri May 20, 2011 10:40 am

With your new (and smaller) driver my report.txt looks like this:
----- dmesg | sed -n /eth/P -----
eth1: RealTek RTL8169 Fast Ethernet at 0xd800, IRQ=10, HWaddr=00:23:f8:5f:3a:ec
eth1: Link Status = OK, PHY Status = 1000 Full-Duplex!
eth1: 1000Mbps Full-duplex Link OK!
eth2: RealTek RTL8169 Fast Ethernet at 0xd400, IRQ=9, HWaddr=00:23:f8:5f:3a:f3
eth2: Link Status = OK, PHY Status = 100Mbps Full-Duplex!
eth2: 100Mbps Full-duplex Link OK!


No full speed indicated, but full duplex achieved.
However the second NIC is attached to a Lyinksys WRT120N modem, maybe that is why speed is so low.

With nothing plugged in the second NIC I get the same message as yesterday.
----- dmesg | sed -n /eth/P -----
eth1: RealTek RTL8169 Fast Ethernet at 0xd800, IRQ=10, HWaddr=00:23:f8:5f:3a:ec
eth1: Link Status = OK, PHY Status = 1000 Full-Duplex!
eth1: 1000Mbps Full-duplex Link OK!
eth2: RealTek RTL8169 Fast Ethernet at 0xd400, IRQ=9, HWaddr=00:23:f8:5f:3a:f3
eth2: Link Status = NoLink, PHY Status = 100Mbps Half-Duplex!

I'll try some Gigabit computer one of these day and will report again.
Who knows knows, who doesn't doesn't.
User avatar
strampke
Junior Advanced Member
 
Posts: 151
Joined: Mon Jul 29, 2002 12:36 pm
Location: Delden, Netherlands

Re: Gigabit behaviour

Postby Lightning » Fri May 20, 2011 7:01 pm

However the second NIC is attached to a Lyinksys WRT120N modem, maybe that is why speed is so low.
Yes exactly, the WRT120N is only capable of 100Mbit full duplex
Linksys WRT120N 802.11b/g/n Wireless Home Router up to 150Mbps/ 10/100 Mbps Ethernet Port x4

With nothing plugged into the card the default is 100Mbit half duplex. As for the driver being smaller, I removed some extra debugging code that was in the other driver. Such as these two lines and the code to enable them that was superfluous.
eth1: Driver info tmp = '16'
eth1: Auto-negotiation Enabled.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Gigabit behaviour

Postby strampke » Sat May 21, 2011 9:09 am

Oh, I forgot; the new driver works like a charm!
Who knows knows, who doesn't doesn't.
User avatar
strampke
Junior Advanced Member
 
Posts: 151
Joined: Mon Jul 29, 2002 12:36 pm
Location: Delden, Netherlands


Return to FREESCO Support for v0.4.x

Who is online

Users browsing this forum: No registered users and 4 guests

cron