VPN from behind freesco problem - again!?

Support section for FREESCO v0.4.x

VPN from behind freesco problem - again!?

Postby ste » Sat Feb 27, 2010 11:32 am

I wrote 'again!?!' since I found a few older "similar" questions, so this may be the same again... but the "solution" given (as far as I can see) is to install the mppe-module - this does however not work for me!

Problem: I want to connect a VPN tunnel (MPPE) from a computer behind freesco to a computer at work, but connection times out!

I'm using Freesco 0.4.2 and have installed the ppp-mppe module:
Code: Select all
[???@???] lsmod
Module      Pages      Used by
ip_masq_ftp        1      0
ip_masq_irc        1      0
ip_masq_quake      1      0
ip_masq_vdolive    1      0
ip_masq_raudio     1      0
ip_masq_icq        1      0
rtl8139.o-n        3      3
ppp_mppe.e-n       3      0
pci-scan           1   [rtl8139.o-n]   1


However, dmesg gets filled with:
Code: Select all
ip_fw_masq_gre(): Outbound GRE to x.y.z.q has no masq table entry.
ip_fw_masq_gre(): Outbound GRE to x.y.z.q has no masq table entry.
ip_fw_masq_gre(): Outbound GRE to x.y.z.q has no masq table entry.
... and so on...


The VPN works fine if I use my LevelOne router instead (which I bought to save space, but it has other issues making me hold on to the otherwise extremely reliable freesco box 8) ).

Is it something I've missed to configure? Has anyone else succeeded to connect mppe vpn through freesco?

Grateful for guidance!

/ste
User avatar
ste
Newbie
 
Posts: 7
Joined: Sat Mar 09, 2002 3:36 am

Re: VPN from behind freesco problem - again!?

Postby Lightning » Sat Feb 27, 2010 1:32 pm

Try setting your firewall in "s" mode and see what happens.
Code: Select all
setup -> system settings -> expert settings = y -> Nat/firewall = s

then use "rc_masq restart" to activate the change.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: VPN from behind freesco problem - again!?

Postby ste » Sun Feb 28, 2010 1:33 pm

Lightning, thanks for your response - as always... :)

I tried your suggestion, I even rebooted with the new settings... But I'm sorry to say it still doesn't work, I still get a couple of:
Code: Select all
ip_fw_masq_gre(): Outbound GRE to a.b.c.d has no masq table entry.

And then the connection attempt fails.

Any other ideas?

/ste
User avatar
ste
Newbie
 
Posts: 7
Joined: Sat Mar 09, 2002 3:36 am

Re: VPN from behind freesco problem - again!?

Postby Lightning » Sun Feb 28, 2010 2:24 pm

Remove the MPPE module as it should not be needed to run a VPN client from behind FREESCO.
However this may be a kernel issue that we can not resolve easily at this point. But that is something that I am looking at.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: VPN from behind freesco problem - again!?

Postby ste » Mon Mar 01, 2010 1:54 am

Well, it doesn't work without the mppe module either - I tried that before I installed it.

If it is to any help I can always try out custom kernels, since I have a backup router that makes me not become stuck while fiddling with the freesco box and my freesco is also on ext2 hdd which ought to make it easier to test kernels compared to a floppy one. However, I'm currently quite heavily loaded with work -> my turnaround time for testing a kernel will probably be a couple of days.

Regards,

/ste
User avatar
ste
Newbie
 
Posts: 7
Joined: Sat Mar 09, 2002 3:36 am

Re: VPN from behind freesco problem - again!?

Postby Slider » Mon Mar 01, 2010 3:59 pm

Good day. You are not belive me, i trying to find solution at the same problem now. :) More, than one year ago i tried to connect provider via VPN by freesco, but unsuccessfull.

My profider gives me next data for external network:
ip 172.16.5.190, mask 255.255.255.252, gw 172.16.5.189, VPN server 192.168.6.6, login and password. When i try to connect with Windows - there are no problems, all works. But with freesco i don't understand, where should i write VPN server IP?
After freesco loads i try pptp 192.168.6.6
Freesco answer, that this network is unreacheble.

It's seems strange to me, that VPN server located in different network, i try make route to this server manually: route add -host 192.168.6.6 gw 172.16.5.189

After that i try pptp 192.168.6.6

I mean, freesco were connect to server and pass authorisation, because my requests "ping domain.name" returns me IP adress of each domain. And no one positive ping's. :(

I think, that i on right way, but i've not enough skill in NIX-systems.

And my English is not so good :(
User avatar
Slider
Junior Member
 
Posts: 29
Joined: Tue Jul 29, 2003 4:22 pm

Re: VPN from behind freesco problem - again!?

Postby Lightning » Wed Mar 10, 2010 9:42 pm

You will have to load the mppe.gz module to get any type of VPN connection working. You will also need to configure the /etc/ppp/pptp.org file special to allow for this type of connection. Which making those changes will require making a copy of the file and putting it in /boot/etc/ppp/pptp.org to survive a reboot and configuring the router as a standard PPtP type of connection to start with.
I strongly recommend making your own thread on this subject as this a lot different subject than what is already started here and please post your report.txt and any modified files in that new thread.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA


Return to FREESCO Support for v0.4.x

Who is online

Users browsing this forum: No registered users and 7 guests

cron