nslookup external DNS server

Support section for FREESCO v0.4.x

nslookup external DNS server

Postby caveman » Wed Nov 11, 2009 6:00 am

Ηι ,

I recently clean installed freesco v.0.4.2 (previous 0.3.4). I did all the setup, and installed in ext2 (good work on that one to developers, thanks)
On the first attempt for setup i did set the DNS server to mode (e) the new mode. I didn't like it though, becase it is some times i need to check some other DNS servers for their entries. Therefore i changed the DNS mode to (s) as i had it on v.0.3.4.

Now from inside the freesco i can nslookup to another DNS server:
example: nslookup www.google.gr ns1.otenet.gr

But if i do the same from a client PC i get i firewall rejected.
kernel: IP fw-in rej eth0 UDP 195.170.0.2:53 192.168.1.111:48772 L=121 S=0x00 I=38127 F=0x0000 T=57

Is there some sort of a bug? And when you change from mode (e) to mode (s), the rule is not removed?
How can i fix this?
You do not have the required permissions to view the files attached to this post.
### there are darker places than your basement ###
User avatar
caveman
Newbie
 
Posts: 16
Joined: Thu Dec 11, 2003 11:12 am

Re: nslookup external DNS server

Postby Lightning » Thu Nov 12, 2009 7:42 pm

Looking at your report.txt I REALLY do not understand your configuration. Because according to the report your external interface is still pointing at a private IP address and the DNS server is still on a private IP address. Which if that is truely the case then to solve the problem you are having you should run FREESCO's caching DNS server in "y" mode to resolve this problem.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: nslookup external DNS server

Postby caveman » Fri Nov 13, 2009 6:00 am

My config is : aDSL modem/router (192.168.1.0) <-> freesco <-> Intranet (192.168.2.0)
Freesco mode is: network
I use freesco as DHCP server that assigns IPs based on MAC address, the caching DNS server to control enties for the local IIS Web Server and few others, the port forwarding, and finally to have a picture of the traffic on the network with ipfm (previously with iptraf and iptotal that are not available for v.4.x yet).
The NAT in the aDSL modem router is also enabled, and in case i need a port forward i do forward from the modem to freesco and then from freesco to any intranet IP. I do not use the DMZ option.
Therefore i think you are correct suggesting to use the DNS in "y" mode, because it is not goin to be visable in the internet anyway.
Thanks
UPDATE: problem solved with DNS mode "y".
### there are darker places than your basement ###
User avatar
caveman
Newbie
 
Posts: 16
Joined: Thu Dec 11, 2003 11:12 am


Return to FREESCO Support for v0.4.x

Who is online

Users browsing this forum: No registered users and 3 guests

cron