problem accessing some sites using PPPoE version

If you need some help, this should be the first place to look.

Postby dingetje » Mon Nov 18, 2002 6:25 am

<font color='#000080'>This text is copied from a post made by TechnoJunky (mr. PPPoE :) ). This howto is only valid for freesco 0.3.0, but the problem is caused by an incorrect MTU setting for both 0.2.7 and 0.3.0.

if you're using pppoe, you need to either <span style='color:black'>lower your client's MTU to 1492</span> or <span style='color:green'>enable Freesco's MSS clamping.</span>

<span style='color:black'>Client's MTU:

The Freesco zip distribution file include another zip file named pppoe4freesco.zip in which there are 2 registry patch files: one for Windows 9x/ME and another for 2000/XP. ?Merge one of them in each of your Windows clients behind Freesco. ?See <a href="http://freesco.tecknojunky.com/027/pppoe/" target="_blank">my pppoe webpage</a> near the end for further detailed explainations. ?In that web page, you'll also see, at the very end, how to lower a Linux box's MTU.</span>

<span style='color:green'>MSS clamping:

Instead of having to lower each client's MTU to 1492, you can enable Freesco's MSS clamping option. ?What this does is that it instruct the pppoe module to rewrite every packets from 1500 bytes down to 1492 bytes. ?This is more cpu intensive but if you have only a few clients with normal traffic... like if only web browsing, taking your mail, and stuff. ?If you host a heavy traffic web or ftp servers, than MSS clamping is to be avoided. ?MSS clamping offers the advantage of leaving all the clients to their default network settings.

To enable MSS clamping, go in the setup, choose 62. Network settings -> 630. ClampMSS.</span>

If you don't use pppoe, then all this is NOT for you and the problem lies somewhere else!</font>



<!--EDIT|dingetje|1041730639-->
dingetje
 

Postby tecknojunky » Mon Feb 17, 2003 10:11 pm

<font color='#0000FF'>Enabling clampsing in 0.2.7 PPPoE Edition:

There is no setup provision for setting MTU and/or clampsing options in the 0.2.7 version.  Never the less, it is possible to enable that option so that boxen that don't have their MTU lowered have their packets rewritten to fit into the PPPoE pipe.

At first, when I did the ramdrive for PPPoE Edition, I had a good behaving ISP that set my MTU thrue DHCP.  When I switched ISP, I  suddenly understood why some reported their MTU still set to 1500 because this new ISP of mine did not set it thrue DHCP.

So the following will assure you have Freesco's ppp link MTU set properly AND rewrites the packets of those boxen that don't have their MTU lowered to 1492.

Everything can be done by modifying the single line of rc_net that calls the pppoe client:
Code: Select all
...
      pppd defaultroute mru 1492 mtu 1492 pty "pppoe -m 1452 -I $INTNAME0"
...


Rule of thumb: the pppoe -m option must always be 40 bytes less than the pppd MTU/MRU options which in turn should be at least 8 bytes less than the MTU of the Nic's interface (usually is 1500).

This takes care of all possibilities.  If your clients don't have their MTU lowered, the packets will get rewritten.  The side effect is a lost of performance since this rewritting process is CPU intensive.  No need to say that setting the clients MTU will give the best results, but with clampsing on, your sure everyone will access the web properly regardless hot their MTU is set.</font>



<!--EDIT|tecknojunky|1045540136-->
<b>TJ</b><br><br><i><b>freescosoft.ca</b> is <a href='http://www.freesco.org/support-forum/index.php?showtopic=16598' target='_blank'>up for grab</a>.</i>
User avatar
tecknojunky
Advanced Member
 
Posts: 220
Joined: Wed Dec 19, 2001 8:04 am
Location: Montréal, Qc


Return to FAQ - Frequently Asked Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron